Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:14

Safari 1.2 + 5.0 - 5.02


Poster: mquattrone
Dated: Wednesday February 18 2004 - 18:40:29 GMT

Hello, I have been working with 5.0 for a few weeks now and everything has been going well and working as expected. I upgraded to Safari 1.2 and suddenly my pull downs work but when I roll over them they disappear. The menus are on top of a short flash box but it hasn't been a problem in the past, especially after the flash stops and it works correctly in all the other browsers that I tried.

I downloaded and installed 5.02 with the same result.

Test site: http://atto.unconformity.com/
The .js files are in: http://atto.unconformity.com/js/

Michael
OSX 10.3.2, Milionic 5.0 + 5.02 (Currently 5.02) Safari 1.2 (v125)


Poster: John
Dated: Wednesday February 18 2004 - 20:10:38 GMT

Will look at it when I get home tonight (stuck with Windoze here at work :( ). Meantime somebody might beat me to it (Maz??).


Poster: Maz
Dated: Wednesday February 18 2004 - 20:33:31 GMT

I would if I could but I'm no help with flash.

Your submenus are going behind the image, I'll assume its flash.

You might search the forum to find any tips on using flash. I'm not sure if there is a flash example on menu examples.

Does it make any difference removing the script from header and placing it just under the body tag?

Regards,
maz


Poster: mquattrone
Dated: Wednesday February 18 2004 - 21:17:53 GMT

The flash has stopped and not doing anything, you pull down a menu and the entire submenu displays correctly, it's when you move your pointer down to select a submenu does the menu disappear but the link your pointer is on stays displayed.

Keep in mind everything was working 100% of the time before upgrading to Safari 1.2. All the menus and submenus displayed all the time, before, during and after the flash was playing.

Michael


Poster: Maz
Dated: Thursday February 19 2004 - 0:05:36 GMT

Its a bit weird, when you pointer over submenus they dissappear except where the pointer is, if you keep going the menu reappears under the pointer. But it only occurs over the image.

With 1.2 Safari also came new java, try sending a bug report to Safari.

Maybe someone else has a clue?

maz


Poster: John
Dated: Thursday February 19 2004 - 0:45:48 GMT

No clue here, but I am seeing the same thing (now that I'm home on a decent machine!).

The first menu you hit drops and then disappears immediately. The next menus are all OK. Reload the page and the problem is back.

Andy will take a look at it, but I think Maz has the right idea - drop Apple a report with your link.

Sorry we can't be more help right now.


Poster: Andy
Dated: Thursday February 19 2004 - 11:27:01 GMT

Hi,

This is due to the Flash on the page.

You can see this by setting the top position of your menu to 60. The menu isn't being dropped but it's being hidden by the Flash object.

I'm not sure how this problem can be fixed, it's definately a bug in the browser but Apple will NEVER admit to this or even fix it so as always, it's down to us again.

The problem is due to the Flash object as it runs. Once it has finished the menu is fine.

Sorry I can't be of more help at the moment.

Cheers
Andy