Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:23

Menu does not show at all in IE and NS


Poster: chrisduif
Dated: Wednesday October 8 2003 - 16:25:51 BST

I thought I had it all fixed after shifting to version 5, but after loading it to the server it turned out that the menu is only visible with Opera (v 6.02) and not with NS or IE.
Also, in Opera, when using the Back button after visiting a link, the menu does not show but you have to reload.
Who gives a hint what might be the problem?

The menu itself is great, so we surely want to buy a lisence.
The page in question:
http://iriaxp.iri.tudelft.nl/~sfwww/newindex.html

Thanks,
Chris


Poster: kevin3442
Dated: Wednesday October 8 2003 - 19:54:50 BST

Hi Chris,

Your page generates three erros while loading. After a quick look at the page, I'd say that the most likely culprit is the addition of an extra line (line 17) in the milonic_src.js file that contains three non-js characters. That's probably throwing off everything else down stream. Remove that last line or, better yet, download the latest update (you are a couple behind).

Hope that helps,

Kevin


Poster: chrisduif
Dated: Thursday October 9 2003 - 15:11:26 BST

Well .... it improved in the sense that now it also appears in Netscape 4.7 (but doesn't work). I downloaded the last version of milonic_src.js.

thanks anyway.
Chris :?


Poster: John
Dated: Thursday October 9 2003 - 15:22:46 BST

I see a couple of problems...

1. You've been messing with the _src.js file. I'd strongly suggest posting it AS YOU RECEIVED IT!

2. You have different versions of the main code files posted. When you update, ALWAYS REPLACE ALL 3 MAIN FILES.

Come back when that's all fixed.


Poster: chrisduif
Dated: Monday October 20 2003 - 10:32:00 BST

Dear John,

When I load the freshly unzipped, original files to the server the menu isn't visible either:

http://iriaxp.iri.tudelft.nl/~sfwww/menu.htm

I have nothing changed in these files.

regards,

Chris[color=darkblue][/color][b][/b]


Poster: John
Dated: Monday October 20 2003 - 15:05:46 BST

You've got some junk in your milonic_src.js file - line 17 specifically. It's []H[] (kindof). Shows up at the bottom of your page as well. Delete that line.

Better yet, we're now on RC17, about 5 levels in. That puts you pretty far back. I'd download again and get caught up. Many fixes since RC15.


Poster: chrisduif
Dated: Friday October 24 2003 - 14:29:17 BST

OK, it is working now :)

[ http://iriaxp.iri.tudelft.nl/~sfwww/ ]

Thanks a lot!

The only thing is still that in some browsers (e.g. NS7.1) OnMouseOver does not work always, i.e., you then have to click in order to unfold the menu.

For the rest: great

Chris