Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:34

Any update of version 4?


Poster: Anonymous
Dated: Tuesday March 11 2003 - 17:19:18 GMT

It has been awhile since I have seen anything posted from the developer(s)? about version 4. I love this menu script, but I am dying to see the new stuff, and see what type of revision I am going to have to make to my current setup. I am not above inputting all my info into an XML file if that is the future of the script, but I am just hoping to hear something soon. :D


Poster: Andy
Dated: Wednesday April 2 2003 - 23:36:47 BST

We should have something in the next week or so - mid April 2003

Once we have a standard release we'll make a start on the XML work

-- Andy


Poster: Hergio
Dated: Friday May 2 2003 - 12:40:44 BST

Whats the word? Its been a month. Anything you can give us to chew on while we wait for the final release?


Poster: Andy
Dated: Friday May 2 2003 - 12:42:45 BST

You can get ya gums around this if ya like :D

http://www.milonic.com/4beta/menu.htm

Cheers
Andy.

date for release !


Poster: henrik __at__ itide.dk
Dated: Monday May 12 2003 - 13:42:51 BST

Hi Andy

Is version 4 soon ready for release ?

We want to use it on a new site :)

Thanks

Henrik


Poster: John
Dated: Monday May 12 2003 - 15:01:39 BST

As Andy mentioned in his note just prior to yours - give it a try at http://www.milonic.com/4beta/menu.htm.

When I checked last week it was b4, and has been very stable in my testing.

How To Use


Poster: dwlarson
Dated: Tuesday May 13 2003 - 20:53:26 BST

Can you provide the steps required to use the new version 4 menu?

I am currently using 3.5.15 and downloaded the new beta 4. I didn't see any information on how to use the new files asa replacement for the old.

TIA

Don


Poster: John
Dated: Tuesday May 13 2003 - 21:06:57 BST

Since Andy is deeply involved in development and it's still a beta, there is no documentation as yet. Those of us running the beta have just ripped apart the examples he included with the download to see how it works and gone on from there. It is different from 3.x, but not as tough as it looks at first glance.

For instance, if you need a horizontal menu just take a look at the included horizontal_data.js to see how it works. Make a copy of the file and edit your menu info into the copy (just in case!).

version 4.0 Beta 1.05 Problem Viewing Menus


Poster: dwlarson
Dated: Sunday May 18 2003 - 6:16:07 BST

I'm working with the 4.0 Beta 1.05 menu using Mac OS 10.2.6 and Safari latest build 1.0 Beta 2 (v74).

When I go to the sample page at <http://www.milonic.com/4beta/horizontal.htm> I am able to see and use the horizontal menus.

If I save the page and related files to a folder, "menu_test" on my local drive, I can not see the menus when I open the "horizontal.htm" file in Safari.

The same problem occurs when I use Internet Explorer 5.2.2 to open that file.

I can view the same page, <http://www.milonic.com/4beta/horizontal.htm> from Internet Explorer on a Windows XP System. If I save the page and related files in a folder on the Windows XP local drive, the same problem appears as when I try to view them on the Mac locally.

This is pretty frustrating to me. Why don't the files saved locally work the same as your web server?

I have copied the unaltered files from the web page <http://www.milonic.com/4beta/horizontal.htm> into a folder on my server at <http://www.timeoutofmind.com/menu_test/horizontal.htm>. At the top level of that same folder are the files: horizontal_data.js and milonic_src.js. There is also a folder there, "horizontal_files" containing the same two .js files. I can't see the menus from a Mac nor a Windows XP system.

I have worked on this for three hours and if I'm missing something, I can't think of what it is. I recall an earlier message a couple months back where someone indicated they were having success with beta 4 and Safari.

Any help would be appreciated.

p.s. My site at <http://www.timeoutofmind.com/> using the latest 3.x.x release version doesn't work well with Safari, although it does work with Internet Explorer on the Mac. :-)


Don


Poster: kevin3442
Dated: Sunday May 18 2003 - 10:46:55 BST

Hi Don,

I'm going to guess that the scriptpath variable in milonic_src.js is not set properly.

Kevin

Scriptpath


Poster: dwlarson
Dated: Sunday May 18 2003 - 18:48:05 BST

The scriptpath is set to null in the "milonic_src.js" file. Curiously, the <script> element in the "horizontal.htm" file looks for the scripts in the "/horizontal_files/" path.

It doesn't matter, because adjusting the scriptpath variable or <script> location attribute fails to solve the matter.

Something is causing the discrepency between what the Milonic example page renders and what the files constituting that example page produce.

Perhaps if the files actually used to render the example page were contained in a linkable zip file, further analysis could rveal the differences?

Don


Poster: John
Dated: Tuesday May 20 2003 - 15:03:28 BST

Hi Don -

Looks like you might have us stumped on this one...

Did you put all the Milonic files into /horizontal_files/, including /images/?

I think Kevin is right when he suggests a problem with the scriptpath variable. You can see my work-in-progress at http://westcgi.west.asu.edu/sai/indextest2.cfm. Note how I reference the location in scriptpath - /sai/templates/menu4/.

Okay, Getting Close Now


Poster: dwlarson
Dated: Wednesday May 21 2003 - 2:55:55 BST

John,

Thanks for your patience. :-)

I had a typo that was, as usual, hard to see. I mostly have it working now.

Let's say I have a top menu named "First" about 300 pixels down from the top of the window and 180 pixels to the right of the left-hand side. Under that "First" menu I have a submenu called named, "Second". Those menus appear as desired and act properly when moused-over.

The problem I have now is when a menu item of "Second" calls another submenu, "Third"; the hierarchical menu of "Third" appears at the top of the window above the horizontal set of menus instead of adjacent to the indicated "Second" menu item at that mouse pointer location.

If I can get the indicated submenus to appear at the desired level and next to the calling submenu, I think I'll be ready to deploy.

TIA

Don


Poster: John
Dated: Thursday May 22 2003 - 15:59:17 BST

Don -

We're going to need a URL so we can see the array.

Also, please start a new thread in Help & Assistance with your last question as we've gotten a bit off-topic here. This is more for development info than help.

Thanks.