Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Archived Topics for the old Version 3.0 JavaScript Menu
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:36

Menu loads slow


Poster: MsKitti
Dated: Wednesday October 30 2002 - 14:44:04 GMT

My menu is slow loading, very slow and is not as large as some other website menu's and they load faster then mine does. I have tested the site without the menu and all is very fast loading. With the menu, so-o-o-o slow. I have not uploaded the website to it's own server, I am a web designer and the website is residing in with my personal space on the server.

http://www.vizualelements.com/clients/template1004/layout1/index.html.

Any suggestions :?:

Have a nice day,
Ms. Kitti


Poster: trytrix
Dated: Wednesday October 30 2002 - 21:24:53 GMT

Hi,

Went to the given URL, but .. the menu doesn't show-up at all !!
When I copy your "menu_array.js" and "defaultsafe.css" on my local drive everything works as expected !!!!

Cheers,

Trytrix

(Hit me at http://www.ransbecca.be)

Menu did not showup at all


Poster: MsKitti
Dated: Wednesday October 30 2002 - 21:40:12 GMT

I clicked on the above link and all is well. Except the menu loads first and then the content loads second. It takes forever, it seems anyway, for the content to show.

What browser are you using? I am using IE 6 on a Windows XP machine.

Ms. Kitti


Poster: trytrix
Dated: Wednesday October 30 2002 - 21:45:43 GMT

I'm using IE 6.0.2600 and Windows 2000 Professional

Cheers

Trytrix

Don't understand


Poster: MsKitti
Dated: Wednesday October 30 2002 - 21:50:17 GMT

I'm not understanding why you can't view the webpage behind this link. What do you think. I also viewed the link in Netscape 7.

:?: :?

Ms. Kitti


Poster: trytrix
Dated: Wednesday October 30 2002 - 21:56:12 GMT

The webpage shows ip,but .... without the menu !!

Trytrix

Re: Menu loads slow


Poster: John
Dated: Thursday October 31 2002 - 14:00:39 GMT

MsKitti wrote:My menu is slow loading, very slow and is not as large as some other website menu's and they load faster then mine does.


Went to the URL you posted and the menu does come up first (immediately, as Andy has said it almost always will), followed by your complete page no more than 1 second later. I'd say that's pretty good, and I don't really see where your problem is. Latest IE6 and XP.


Poster: MsKitti
Dated: Thursday October 31 2002 - 16:10:31 GMT

Thank you for your input, jgillett. I have moved the website, which has the menu, to my clients host server. Here is the link:
http://www.mptinc1.com/index.shtml.

Now, when I pull up the homepage, it takes some time. Too long for me. Is there anyway to have some content showup for viewing to ease the wait. Maybe surfers won't notice the loading time as much. I have optimized everything as much as it can be, so I need another solution.

I am using dialup. Can't get any faster conection yet. I live in the country and I am waiting for any type of service that offers a faster connection to service our area.

Anyway, what other solution can you think of, jgillett?

Ms. Kitti


Poster: John
Dated: Thursday October 31 2002 - 16:17:09 GMT

Maybe I caught you between loads, but right now I see a site that pops up instantly and no menu at all (probably because I don't see any calls for it in the code)! Gotta think it's your connection rather than your coding.


Poster: MsKitti
Dated: Thursday October 31 2002 - 16:32:24 GMT

I don't believe I was working on the pages at the time you had visited. Please try again if you will.

Ms. Kitti

The link: http://www.mptinc1.com/index.shtml


Poster: kevin3442
Dated: Thursday October 31 2002 - 19:02:20 GMT

Hi Ms. Kitti,

The only suggestion I have is to move the code that loads the menu scripts (menu_array.js and mmenu.js) out of the <HEAD> and into the <BODY>. I and other participants in these forums have occasionally experienced odd behaviors when loading the scripts in the <HEAD>. Don't know why, but there you have it. Worth a try anyway.

Just FYI: For me (IE6, W2K, cable), the menu appears instantly, followed by the rest of the page very shortly thereafter (1 second or so).

Kevin


Poster: MsKitti
Dated: Thursday October 31 2002 - 19:29:52 GMT

I moved the menu scripts from the head and have placed them in the body just after the body tag.

What do you think and can you see any difference?

I did notice however, that the menu doesn't load immediately now.

http://www.mptinc1.com/index.shtml

If it is better to have them in body anyway, then I will leave them.

Ms. Kitti

page laoding


Poster: Jack D. Ripper
Dated: Thursday October 31 2002 - 22:52:34 GMT

Your page loads just fine for me, IE6 NS7. Like someone else said, the menu laods quickly and the rest follows within a second or so. I'm on DSL and things are fast. Your menu is not slow either. Nice work on that site.


Poster: MsKitti
Dated: Friday November 1 2002 - 0:20:45 GMT

Thank you guys for all the help. Appreciated.

Thanks for the comment as well, Jack.

MsKitti

Image

http://www.vizualelements.com