Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Archived Topics for the old Version 3.0 JavaScript Menu
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:35

Danish letters wil not appear first time menu is loaded??


Poster: Flemming Runing
Dated: Monday November 18 2002 - 21:30:17 GMT

Hi there.....

When using Danish char (æøå) - the first time time the menu is diplayed, it shows the letter "f" instead and another font. When i choose a submenu item, and return to mainpage, it shows the letter and font correct.

Any ideas??

/Flemming
[All your base are belong to us]


Poster: kevin3442
Dated: Monday November 18 2002 - 22:55:07 GMT

Hi Flemming

If you can post a URL that we can use to investigate further, it will make it easier for people in this forum to help.

In the meantime, I'll take a wild guess. I'll assuming you load the two menuscripts at the top of the <body>, as most people do. If so, you may notice that the menus are the first thing to appear, as the page is loading. I don't use Danish characters myself, but given the behavior you've described, it may be reasonable to suppose that the appropriate character set is not available when the page starts loading. There are some things you could do to see if this is the case. Does the main menu render correctly if you minimize the window then restore it (forcing a redraw of the window)? If so, that would support the hypothesis. Are the submenus rendered with appropriate characters? If so, try setting the Always Visible property of a submenu to 1 (as a test), it should now be opened automatically when the page loads... does that submenu now use the wrong character set, like the main menu? If so, that would support the hypothesis.

If the availability of the character set is the problem, maybe we can figure out a workaround... like using PlaceMenu() after the page loads, poping the main menu from the body's onload event, or moving the lines that load the menu script to just before the closing </body>. But let's verify the cause first.

Kevin